Plesk Extension

Available for both Windows and Linux.

The minimum supported version of Plesk is now 18.0.15 and works with PHP 7.4.22.

Download Extension

Downloaded the extension directly from the official Plesk Catalog here.

Installation

Our new Plesk Extension documentation can be found here.

Bug reporting

Please report any issues directly to our support team at support@spamexperts.com.

Before reporting any issues with our support team, you need to ensure the SMTP server is properly configured with all appropriate ports open and not blocked in order for it to send emails.

For Spam Experts extension purchased from Plesk Catalog

Installing the Plesk Extensions with the license purchased from the Plesk Catalog should automatically pre-populate all settings. If you need to contact support after setting the extension up, navigate to the support tab and fill in the support form.

If the support form is not available to you, it means that you did not yet purchase / set up the Plesk Extensions. Please contact Plesk support for assistance with purchasing and adding the license.