
How to Create Custom Reports

Version 4.0



2

Contents

About this guide 3

How to Create Custom Reports 4

#1 Setting Up an Account for Working in Report Builder 5

#2 Accessing Report Builder 8

#3 Exploring Key Features in Report Builder 10

#4 Create Reports 26

Creating a Missing Patches Report 26

Creating a CPU and Disk Utilization Report 49

Creating an Executive Summary Report with Hardware Inventory 59

#5 Previewing Custom Reports in Report Builder 73

#6 Configuring UI Controls in Report Manager 79

Managing Custom Reports in Report Manager 93

Uploading a Custom Report File 95

Deleting a Custom Report File 97

Resources for Custom Report Creation 98

Restoring Templates 98

Previewing Templates in Report Manager 98

Tips and Tricks 99

Data Tables 110

About Report Builder and Report Manager 114

More Reading 114

Index 115

Customer Support 118

March 12, 2013

Report Manager 4.0



3

About this guide

This guide applies to the following version(s) of Report Manager:

l 4.0
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How to Create Custom Reports

Report Manager Custom reports put you in charge. Within minutes of getting a question from sales or customers you can build
and generate a report with the answers. It is our hope that this manual will help you accomplish all your reporting tasks
through Report Builder and Report Manager with speed and grace.

How to use this manual

If you are new to custom reporting, follow the step-by-step instructions to help you get comfortable with the Report Builder
and Report Manager features. Then use the information provided here as a reference.

If you have some reporting expertise, it is our hope that this helps you as a quick review and reference.

This manual takes you step by step through custom report creation. You will setting up an account to use to create reports
and ultimately learn to configure UI controls. The table below, Step by Step on page 4 provides the order of topics to follow as a
start to custom report creation in Report Builder.

Step by Step

Step Topics What's in it?

Step 1 #1 Setting Up an Account for Working in
Report Builder on page 5

This topic describes creating the account
needed for report creation and configuring
the Role it plays in SQL Server Reporting
Services.

Step 2 #2 Accessing Report Builder on page 8 This topic describes accessing Report
Builder.

Step3 #3 Exploring Key Features in Report
Builder on page 10

This topic provides a walk through of key
features in the Report Builder envi-
ronment.

Step 4 Create reports and preview them in Report
Builder:

l Creating a Missing Patches
Report on page 26

l Creating a CPU and Disk Util-
ization Report on page 49

l Creating an Executive Summary
Report with Hardware Inventory
on page 59

This topic gives you the tools to create
ready-to-use reports using templates and
report parts.

Step 5 #5 Previewing Custom Reports in Report
Builder on page 73

This topic takes you through the steps to
preview a custom report in Report Builder
so that you can make adjustments to for-
mat and contents before uploading to
Report Manager.

Step 6 #6 Configuring UI Controls in Report Man-
ager on page 79

This topic shows you how to use the fea-
tures in Report Manager's Custom Report
Management.

Report Manager 4.0 How to Create Custom Reports
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Temp l at e and R ep o rt Part s t o p i cs are no t i n th e PDF

Template and Report Parts topics (documentation about each indiv idual Template and Report Part) are not
included in the PDF version of this manual. For Template and Report topics, please refer to the online he lp
within Report Manager.

The reason for this is that we update Report Parts and Templates frequently , and the latest will a lways be in
the online he lp.

To v iew the online he lp, c lick the question mark icon in the top r ight corner of any screen in Report Man-
ager.

Managing Custom Reports in Report Manager
This section provides you with an overview of the features of Custom Report Management in Report Manager, and how to
upload custom reports.

Resources
This section includes:

l Previewing Templates in Report Manager on page 98—Use sample Templates to plan your reports. You can preview the
information in the Template or Report Parts andmake decisions about which ones to use.

l Tips and Tricks on page 99—Find answers to some questions users have had and some gotchas we've uncovered in our
work with Report Builder. We are always looking for more suggestions for this section.

l Data Tables on page 110—Advanced users will find dimension and fact tables for Report Manager here to use in the cre-
ation of custom reports.

l About Report Builder and Report Manager on page 114—Which versions of SQL Server and Report Builder are com-
patible? What are the roles of Report Manager and Report Builder in custom report creation.

l More Reading on page 114—The details of some books we recommend to round out your reporting knowledge.

We'd love to hear from you about your experience with Report Manager and especially about the documentation.

#1 Setting Up an Account for Working in Report Builder
This topic shows you how to set up an account with restricted permissions for report creation.

This is important because Templates for custom report creation are located on the Report Manager server in SQL Server
Reporting Services. If you clickedSave or Save aswhen using an Administrator account with rights to SQL Server Reporting
Services, you could accidentally overwrite the Templates.

Set up an account
The account that you set upmust meet the following conditions:

l Local to the Report Manager Server
l Not part of the Administrator group
l Not a user or part of a group that has been granted the Content Manager role within Reporting Services

Users with this account will only be able to save the modified Template locally or to a location to which they have write
access.

Report Manager 4.0 How to Create Custom Reports
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What yo u w i l l s ee i f yo u t ry t o S ave o r S ave as w i th th i s acco un t

This account will give you the following error:

"The permissions granted to user 'WIN-NQFZC7D1CLI\ReportAuthor ' are insuff ic ient for
performing this operation."

Assign the account the N-able Custom Report Author role
1. RDP to the Report Manager server using the Administrator account.

2. On the Report Manager server, open a browser.

Warning! If you are using Internet Explorer as your browser, you need to run IE as an Administrator.

3. Browse to http://localhost/Reports.

4. Click Folder Settings in the menu bar.

5. ClickNew Role Assignment.

Report Manager 4.0 How to Create Custom Reports



7

6. In theGroup or user name field, specify your account name in the domain\user format.

7. Select theN-able Custom Report Author checkbox.

8. ClickOK. This account is the one you should always use to create reports.

Note: If you ever do accidentally overwrite your Templates, don't despair, we have included a back-up resource for you. Refer
to Restoring Templates on page 98.

Report Manager 4.0 How to Create Custom Reports
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Next step: Use the new account to open Report Builder and follow the next topics to learn about Report Builder and custom
report creation.

#2 Accessing Report Builder
You can use Report Builder locally and remotely. You can access Report Builder through Report Manager or through a stand-
alone you have installed on the Report Manager server.

Warning! If you have installed Service Pack 2 for SQL Server 2008 R2, and plan to use Report Parts, you cannot reliably use
the version of Report Builder available through the SSRS interface or directly through Report Manager. You need
to download and use a stand-alone Report Builder, version 10.50.1600.1, available here:

http://www.microsoft.com/en-us/download/details.aspx?id=6116

This is due to a Microsoft issue in the version of Report Builder installed with SQL Server 2008 R2 SP2, which
causes errors when custom reports are created using Report Parts. The Report Manager team has opened an inci-
dent case with Microsoft regarding this issue.

Note: You need at least SQL Server 2008 R2, as all Report Manager Templates and Report Parts are designed for use with
Microsoft Report Builder 3.0, which only works with SQL Server 2008 R2 and greater.

l Credentials to use if you plan to work with Templates on page 8
l Using Report Manager to access Report Builder on page 9
l Using a Stand-alone to access Report Builder on page 8

Prerequisites for accessing Report Builder
The prerequisites for using Report Builder were given in the installation guide, but just in case you have trouble, here
are a few things you absolutely need to have:

l An account that will prevent the overwriting of Templates. For more information, refer to #1 Setting Up an
Account for Working in Report Builder on page 5.

l Microsoft .NET Framework 4.0 must be install on the machine on which you are going to use Report Builder.
l To use Firefox as your browser, you need to download the Microsoft .NET Framework Assistant add-on through
Tools > Add-ons, which allows Firefox to run .NET ClickOnce applications, such as Report Builder.

Credentials to use if you plan to work with Templates
l Logged in remotely. If you are logged in remotely, when you open Report Builder you will be prompted for cre-
dentials. Ensure that you use the credentials that will prevent the overwriting of Templates. For more infor-
mation, refer to #1 Setting Up an Account for Working in Report Builder on page 5.

l Logged in locally. When you log in to the server, use the credentials that will prevent the overwriting of Tem-
plates. When prompted for credentials, use these same credentials. For more information, refer to #1 Setting Up
an Account for Working in Report Builder on page 5.

Using a Stand-alone to access Report Builder
If you download and install the stand-alone on the Report Manager server, you can access Report Builder directly with-
out going through Report Manager.

1. Download the stand-alone installer for Report Builder 3.0 from the Microsoft Download Center (http://ww-
w.microsoft.com/en-us/download/details.aspx?id=6116).

2. Follow the instructions in the installer, clickingNext for each screen, until theDefault Target Server screen.

Report Manager 4.0 How to Create Custom Reports
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3. For Default target server URL, provide the following: http://*ip*/reportserver where *ip* is your local Report Man-
ager server IP.

4. ClickNext.

5. Open Report Builder from the Start Menu or pin it to the Taskbar before beginning your custom report work.

Using Report Manager to access Report Builder

Warning! This method is not recommended if you have installed Service Pack 2 for SQL Server 2008 R2.We recommend
that you download the standalone Report Builder, version 10.50.1600.1 instead.

Report Builder is available through the Administration Console of Report Manager.

1. In the N-central navigation pane, click Administration > Report Manager > Administration Console.

2. Sign in using the appropriate credentials.

3. Click Custom Report Management.

4. Click Report Builder.

Report Manager 4.0 How to Create Custom Reports
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5. The first time prompted, use the credentials that you have been providedwith for report creation. For more infor-
mation, refer to #1 Setting Up an Account for Working in Report Builder on page 5.

6. If you are using Internet Explorer as your browser, ensure that you select Remember my password to allow the
connection.

7. ClickOK.

Report Builder opens.

Troubleshooting access through Report Manager
If you are unable to run Report Builder when opened through Report Manager and there is no prompt for credentials,
use the following procedure: 

1. On the Report Manager server, click Start > Run.
2. Type control userpasswords2.

3. Click OK.
4. In the User Accounts dialog, select the Advanced tab.
5. ClickManage Passwords.
6. Click Add.
7. In the Logon Information Properties dialog, provide the Report Manager server name and its credentials

using an appropriate format, for example: <IP\username> or <domain\username>.
8. Click Close.
9. Sign back into the Report Manager Administration Console and start the procedure again.

Next step: Explore the Report Builder 3.0 work environment in the next topic. Refer to #3 Exploring Key Features in Report
Builder on page 10.

#3 Exploring Key Features in Report Builder

What i s R ep o rt Bu i l d er?

Report Builder is a small report design tool that is insta lled on your report server as part of Microsoft
SQL Server. S imilar in look and fee l to Microsoft Word, it is a comfortable env ironment for users of other
Microsoft Off ice tools. You can create simple or complex reports very quick ly through wizards and an intui-
tive interface. I f you have SQL and scr ipting sk ills you can customize SQL quer ies within Report Builder,
but it is often just as quick to fo llow the UI and use the wizards.

This topic walks you through the geography of the Report Builder landscape. It starts with a blank work surface in Report
Builder. (To start with a Template, refer to Creating a Missing Patches Report on page 26.)

After reading this topic, you will have learned about:

l Key features in the Report Builder work surface on page 11
l Setting up the workspace and selecting page settings on page 14
l Adding elements andmore formatting tips on page 15
l Adding a data source on page 16
l Adding a dataset on page 16

Report Manager 4.0 How to Create Custom Reports
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l Using the Query Designer in Report Builder on page 17
l To create a new Dataset on page 19
l To edit a dataset on page 19
l To set up a filter on Customer on page 20
l Query Designer Quick Tips on page 25

Key features in the Report Builder work surface
1. Open Report Builder 3.0. Refer to #2 Accessing Report Builder on page 8.

2. Click Blank Report in theGetting Startedwizard.

3. The work surface is displayedwith a new blank report in the design area.

Report Manager 4.0 How to Create Custom Reports
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Report Data and Report Design
The Report Builder work surface is divided into two sections:

l Report Data. Report data is represented graphically in the left pane. This is where you can search the contents
of the database, and collect the data to build datasets. Each report can have many datasets and each dataset
can be used over and over within the same report.

l Report Design. Report Design is separate from data collection. The report design area is where you will place
report items, such as Report Parts, Subreports, tables, charts, text boxes, images and so on.

At the top of the Report Builder window is the ribbon menu with three tabs:Home, Insert andView.

Home tab: text formatting and at the far left is the run button which allows you to preview the report.

Insert tab: Here is where you will find all the items that you might want to insert into a report.
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Insert tab tip: Click Insert> Report Parts to view the Report Part Gallery:

View Tab: This tab allows you to organize your workspace, to display the Report Data, Grouping, Report Properties
and the Ruler.

View tab tip: Click View > Properties to view the Properties pane.
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Setting up the workspace and selecting page settings
When you use a Template, the ruler and display settings are already set up. The purpose here is a quick walk through
how you can change things up.

1. In the View tab, clear the check boxes for Properties andGrouping. (This opens upmore real estate.)

2. Select Ruler.

3. Right-click on the blue screen beside the layout and select Report Properties from the quick menu.
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4. Set the units and dimensions appropriately for your report.

Adding elements and more formatting tips
For more information on adding elements and formatting them, please refer to the Report Builder online help. In the
Search tab, type "Tutorials" and select List Topics for a great selection of help for adding and editing items within the

Report Manager 4.0 How to Create Custom Reports
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Report Builder design surface.

Adding a data source

What i s a d ata s o u rce?

A data source is a database and the credentia ls to access it.

The Report Manager server is pre loaded with three data sources.

Models/warehouse—This is the main data source to use, this data source has an
interface between you and the raw data, it a llows for drag and drop creation of data-
sets in the Query Design Wizard within Report Builder.

Reports/config—Less often used, this data source conta ins templates, information
used by branding and scheduling,

Reports/warehouse—This data source allows direct access to the data warehouse
and to access data. You need to use SQL quer ies and cannot utilize the wizard fea-
tures of Report Builder when using this data warehouse.

When you open a Template in Report Builder, the data source connection is automatically connected. In the case of a
blank report, you will need tomake that connection manually.

1. Right-clickData Sources, click Add Data Source.

2. Type in a new name for the data source, with no spaces in the name.

3. Select Use a shared connection or report model.

4. Select your <reportserver>/Models/Warehouse. This is the warehouse that provides graphical representation of
the raw data and allows you to use the query designer in order to drag data from the database into the report
designer.

Note: If Report Builder is not showing you a list of pre-loaded data sources, click Browse, type http:/-

/localhost/reportserver/Models. SelectWarehouse and clickOpen.

The new data source with the name you created appears in the Report Data pane under Data Sources.

Adding a dataset

What i s a d atas et ?

A dataset includes a connection to a data source, the query to execute and a fie ld list of
the data types that will appear in the report. A report f ile can have multiple datasets.

An embedded dataset means that it is only used within this report.

In genera l, when creating a custom report, add as many fie lds to a dataset as you think
you might possibly use.

When you open a Template in Report Builder or pull a Report Part into a Template, the associated datasets appear in the
Report Data pane, already set up. In the case of a blank report, you will need to set up each dataset from scratch.

1. Right-clickDatasets, click Add Dataset.

Report Manager 4.0 How to Create Custom Reports
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2. Type in a new name for the dataset, with no spaces in the name.

3. Select Use a dataset embedded in my report. (An embedded dataset is one that you will create here and it will
be used by this report only. A shared dataset is one that has been created and saved on the report server. You
would have to browse to locate it.)

4. Select the a data source.

5. ClickOK.

This has created a new dataset that is connected to the Warehouse data source. To set up a query that will specify
the fields that will provide the data for the report, continue to the next section,Using the Query Wizard.

Using the Query Designer in Report Builder
The Query Designer for Report Models allows you to specify the data that you want to use in a report. For Report Builder

Report Manager 4.0 How to Create Custom Reports
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3.0 there are two ways you can create queries:

l A graphical query designer that works like a wizard, and
l A text-based query designer in which you can work directly in XML

You switch between the views. The graphical query designer is displayed by default when you create or edit a dataset.
Report Manager instructions use the graphical query designer.

If you are in the graphical query designer, as shown, you can click Edit as text to switch to the text-based query
designer.

For more information about the Report Model Query Designer in Report Builder, refer to the following, Microsoft Tech-
net article, Report Model Query Designer (Report Builder 3.0) at http://technet.microsoft.com/en-us/li-
brary/dd220456%28v=sql.105%29

Graphical Query Designer

Click Edit as Text to view the Text-based Query Designer.
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Text-based Query Designer

To create a new Dataset
1. In the Report Data pane, right-clickDatasets .

2. Click Add Dataset.

3. Name the dataset, select Use a dataset embedded in my report.

4. ClickQuery Designer.

To edit a dataset
1. In the Report Data pane, right-click a dataset, for example, newDataset, as shown below.
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2. ClickQuery.

To set up a filter on Customer
To filter the report information so that the customer for the report can be selected at run time, we need to set up a filter
on Customer ID.

1. In the left pane, right-click the dataset, newDataset.

2. ClickQuery.

To set up the dataset as shown:

1. In Entities, clickDim Customer.
2. In Fields double-click Customer ID.
3. In Entities, clickDim Device.
4. In Fields, double-clickDevice Class andDevice Name.

Tip: Widen the columns so you can see the names, by clicking a column and dragging the right column edge over.
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3. Click Filter.
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4. Select the Customer table in the Entities box.

5. Select and drag (or double-click)Customer ID in the Fields list box.
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6. Right-click Customer ID and select Prompt.

By selectingPrompt for Customer ID, the user will be prompted to provide a Customer ID for the report at run-
time.
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7. ClickOK.

8. ClickOK.

9. Right-click Parameters in the left column to see that creating a filter with a prompt has added a new parameter to
the report, Customer_ID.
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Tip: To find parameter ID numbers
(To preview reports in Report Builder you will need ID numbers for many parameters.)

1. In the Administration Console, go to the Advanced settings page and enable the Real-time display of
Report Values.

2. In the Reports Console, run any report with the parameters for which you require the ID numbers.

The parameter values table appears at the bottom of the screen.

Query Designer Quick Tips
Tip: Tables are not listed in alphabetical order, so you can use the search button or scroll.

Tip: Click and drag fields into the right collection field. Or you can double-click them tomove them.

Tip: When you drag a field into the collection screen, look for the blue bar before dropping the field.

Tip: If you drag a field into the collection screen by mistake, right-click the column and clickDelete.

Next step: Create a Missing Patches report using a generic Template. Refer to Creating a Missing Patches Report on page 26.
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#4 Create Reports

Creating a Missing Patches Report
This topic provides step by step instruction to create a Missing Patches report using the Generic Template with no subscription,
creating a dataset, and setting up a filter through the Query Designer.

After completing this topic, you will have learned about:

l Opening the Template on page 26
l What's in a Template? on page 30
l Adding a new dataset on page 32
l Inserting a table on page 39
l Setting up a filter on a customer on page 46

Opening the Template
1. Open Report Builder 3.0. Refer to #2 Accessing Report Builder on page 8.

2. Close theGetting Started page.

The work surface is displayedwith a blank report in the design area.

3. We are going to open a Template on the report server. In the upper left-hand corner of Report Builder, click the icon
and clickOpen.

4. Navigate to your Report Manager server.

5. On the Report Manager server, click Templates.
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6. Click to open GenericNoSubscription_Template.
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The GenericNoSubscription_Template displays in the Report Design area.

Renaming and saving the new report locally
1. Rename the report in the Report Design Surface. Click into the report title text box (it currently displays Custom

Report Template No Subscriptions) and type: Missing Patches Report.

2. Save the report locally to a new name:Missing Patches Report Custom. This is the name that will appear as the title
of the report in the Reports Console and in the list of reports in the Administration Console. For more information
about saving the report locally, refer to #1 Setting Up an Account for Working in Report Builder on page 5.

Report Manager 4.0 How to Create Custom Reports



30

What's in a Template?
This Template includes the following Report Data: Built-in Fields, Parameters, connection to Data Sources (config and
Warehouse), and three Datasets (DateFormat, GetBrandingImage, dsCustomerNames).
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As shown below in the screen capture from the Reports Console, this generic Template is completely branded and con-
figured before wemodify it to become a Missing Patches report.
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Adding a new dataset
To create the Missing Patches report, we are going to add a new dataset, MissingPatches. Our new dataset will connect
to the data source to retrieve the data we need for the report at run time.

What i s a d atas et ?

A dataset includes a connection to a data source, the query to execute and a fie ld list of
the data types that will appear in the report. A report f ile can have multiple datasets.

In genera l, when creating a custom report, add as many fie lds as you think you might pos-
sibly use to a dataset.

1. In the Report Data panel, clickDatasets.

2. Click Add Dataset.
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3. Type in a new name for the dataset: MissingPatches (no spaces in the name).

4. Select Use a dataset embedded in my report. (An embedded dataset is one that you will create here and it will
be used by this report only. A shared dataset is one that has been created and saved on the report server. You
would have to browse to locate it.)

5. Select theWarehouse data source.
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6. ClickQuery Designer.

The Query Designer allows you to pick the fields you want to include in the report. You can drag fields from the left
pane of the Query Designer to the right pane to build an expression that will evaluate and pull data into the report
at run time.
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7. In the Entities list, select theDim Customer table.

When a table is selected, the fields are filtered and the those now available for selection are related to the selected
table. In this case, the fields available are related to Dim Customer.

8. In the Fields list, select Customer Name and drag it to the right pane and drop it in the collection field.
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9. In the Entities list, clickDim Devices. The Dim Devices table has fields that will provide information about devices
for our Missing Patches report, such as device class and device name.

Tip: Tables are not in alphabetical order, so you can use the search button or scroll.

10. In the Fields list, clickDevice Class and drag it into the collection field.

11. Do the same forDevice Name.
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Tip: When you drag a field into the collection screen, look for the blue bar before dropping the field.

Tip: If you drag a field into the collection screen by mistake, right-click the column and clickDelete.

Tip: Widen the columns so you can see the names by clicking a column and dragging the right column edge over.

12. In the Entities list, click Fact Cim Missing Patches ( it's near the bottom of the list of tables).This table has the
information about the missing patches that we can provide in the report.

13. From the Fields list, select and drag the following into the collection pane:Product, Patch Name, Installation
Status,Release Date.
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14. ClickOK.

15. ClickOK.

16. In the left hand pane, you can see the new dataset: MissingPatches.
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Inserting a table
Now that a dataset has been created with the fields specific to reporting on missing patches, we can go ahead and
select a layout for the presentation of the data in the report.

1. Insert a table using the Insert tab: Click Insert> Table >Table Wizard.
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2. In theNew Table or Matrix wizard, select Choose an existing dataset in this report or a shared dataset.

3. Select the existing dataset,MissingPatches.
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4. ClickNext.

5. We are going to use all the Available fields to make up the rows in our report. Press Shift and click all the Available
fields to the Row groups box.

6. Because this screen won't let you leave without placing something in the Values column, drag any field from Avail-
able fields intoValues.
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7. ClickNext.

8. On the Choose the layout (for the table) screen, clear the check boxes.

Tip: For any asset report, disable both check boxes. If you are creating a CPU Utilization report, for example, keep
the first one checked, however, always clear the last.
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9. ClickNext.

10. Choose a style for the report.

11. Click Finish.
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The Report Design surface appears with the table.

Tip: To edit a dataset, right-click the Dataset in the Report Data pane and select Query.
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Removing the Values column

Why d i d we need a f i e l d i n Val u es ?

You must put a fie ld in the Values box in order to leave the Arrange Fie lds screen. Report
Builder has been designed to suit a wide audience and, in particular, business accounting.
Values are useful when you need to create tota ls and subtota ls. Report Manager users might
need fie lds in the Values column, for example, if we were creating a CPU Utilization Report.

On the far right of the table will be the Values column that we were forced to add to the report just to leave the screen,
Arrange Fields. We cannot remove it, but we can hide it from view.We also need to conserve real estate in our report
layout.

1. Click in the table to select it.

2. Click the column itself to select it.

3. Right-click the column top border to display the menu:
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4. Click Column Visibility.

5. In the Change display options dialog, select Hide.

When the report is run, this column will not be visible.

Setting up a filter on a customer
Unless we set up a filter on customer, the report will display information for every customer. We need to set up a filter
so that the report will only display information for one selected customer at a time.

1. In the Report Data pane, right-click the dataset,MissingPatches.

2. ClickQuery.

3. Click Filter.

4. Select the Customer table in the Entities list box.

5. In the Fields list box, select and drag (or double click)Customer ID to move it to the query design pane.
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Why do we f i l t er o n Cu s tomer ID and no t Cu s tomer Name?

Report Manager uses Customer ID to map to the Customer List UI contro l. IDs are a lways
used for filters.

Using IDs instead of names to identify customers makes good sense, from a database per-
spective. I t promotes sca lability .Report Manager stores data for a long time and if a cus-
tomer is removed from Report Manager and subsequently returns, the customer name may
be the same, but the Customer ID will a lways be unique. In addition, if you have multiple
servers, it avoids confusion of different customers with the same name.

6. In the Query design pane, right-click Customer ID and select Prompt.

Report Manager 4.0 How to Create Custom Reports



48

By selectingPrompt for Customer ID, the user will be prompted to provide a Customer ID for the report at run-
time.

Tip: To find parameter ID numbers
(To preview reports in Report Builder you will need ID numbers for many parameters.)

1. In the Administration Console, go to the Advanced settings page and enable the Real-time display of
Report Values.

2. In the Reports Console, run any report with the parameters for which you require the ID numbers.

The parameter values table appears at the bottom of the screen.

3. ClickOK.

4. ClickOK.
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5. Right-click Parameters in the left column to see that creating a filter with a prompt has added a new parameter to
the report, Customer_ID.

6. Preview the report in Report Builder. For more information, refer to #5 Previewing Custom Reports in Report
Builder on page 73.

7. Upload the report to Report Manager. Refer to Managing Custom Reports in Report Manager on page 93.

Next step: Create a report using a Template and Report Parts in the next topic.

Creating a CPU and Disk Utilization Report
In this topic, we will use a generic Template and add Report Parts to the Template to create a customized Technical Summary
Report.

Before beginning here, ensure that you reviewed the following: #1 Setting Up an Account for Working in Report Builder on
page 5, #2 Accessing Report Builder on page 8 and#3 Exploring Key Features in Report Builder on page 10.

After completing this topic, you will have learned about:

l Workflow to follow for all reports built using a Template and Report Parts
l Opening the Template and saving it locally on page 49
l What's in the Template? on page 52
l Adding Report Parts to the Template on page 53

Workflow to follow for all reports using Report Parts
Tip: Open the online documentation, as you will need the filename of the Report Part or Parts.

1. Open Report Builder.
2. Open the GenericWithSubscription_Template (for IT reports) or the GenericNoSubscription_Template (for Asset

or other point-in-time reports).
3. Open the Report Manager documentation to get the Report Part name on which to search in Report Builder.
4. Locate Report Parts topics within the online help (Creating Custom Reports> Report Parts).
5. Locate each Report Part topic, for example, within Report Parts you will find Technical Summary Report Parts and

pictures and configuration details for all Technical Summary Report Parts.
6. For each Report Part you would like to use:

1. Locate the section,Name to search on in the Report Part Gallery.
2. Record the name that you use in a list.
3. Copy the name from the documentation and return to Report Builder.
4. Paste the name into the search window of the Report Part Gallery.
5. Click and drag report parts into the report layout and format them.

7. Save the report locally and upload the report to Report Manager.
8. Follow the list of Report Parts and use the documentation for each Report Part to configure the UI controls.

Opening the Template and saving it locally
1. Open Report Builder 3.0. Refer to #2 Accessing Report Builder on page 8.

2. Close theGetting Started page.

3. The work surface is displayedwith a blank report in the design area.
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4. We are going to open a Template on the report server. In the upper left-hand corner of Report Builder, click the icon
and clickOpen.

5. Navigate to your Report Manager server.

6. On the Report Manager server, click Templates.

7. Click to open GenericWithSubscription_Template.
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The GenericWithSubscription_Template displays in the Report Design area, titled Custom Report Template with
Subscriptions.

Rename and save the report locally
1. Rename the report in the Report Design Surface. Click into the report title text box (it currently displays Custom

Report Template No Subscriptions) and type: CPU and Disk Utilization.
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2. Save the report locally to a new name: CPU and Disk Utilization. This is the name that will appear as the

title of the report in the Reports Console and in the list of reports in the Administration Console. For more infor-
mation about saving the report locally, refer to #1 Setting Up an Account for Working in Report Builder on page 5.

What's in the Template?
This Template is completely branded and includes the following: Built-in Fields, Parameters, connection to Data Sources
(config andWarehouse), and three Datasets (DateFormat, GetBrandingImage, dsCustomerNames).
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Adding Report Parts to the Template
1. After the Report is saved, we can add Report Parts to the Template. If the Report Part Gallery is not already dis-

played, on the menu bar, click Insert> Report Parts to display the Report Part Gallery.

The Report Part Gallery is displayed on the right-hand side of the report layout.

2. To add a first Report Part, open the online documentation.

3. Locate the Report Parts documentation:Creating Custom Reports> Report Parts> individual files contain
names of all Report Parts.

4. Open the Technical Summary Report Parts topic and locate the CPU Utilization Report Part. Locate theName to
search on in the Report Part Gallery: TechnicalSummary_Chart_CPUUtilization_SQL.

5. Locate the next Report Part, CPU Utilization Report part, theName to search on in the Report Part Gallery:
TechnicalSummary_Chart_CPUUtilization_SQL.
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6. Copy the name from the documentation and paste it into the Search Name and Description window in the Report
Part Gallery.

7. Make a note (copy to a file or jot down on paper) of the names of Report Parts that you use in the creation of a
report. Then, when you go to configure the UI controls, you will know which Report Part topics in the online help to
refer to for the order and configuration of UI controls.

Tip: You can use partial names to search and then select the Report Part from the search results.

8. Click the search icon in the window.
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9. The Report Part Gallery refreshes to display the link to the report part.

Tip: You can toggle between viewing the link to the Report Part as Details or Thumbnail.

10. Click and drag the Report Part link into the design surface of the report. This pulls the Report Part and the asso-
ciated datasets into the report.

11. Use the handles to drag it to the far left of the design pane so that it lines upwith the edge and drop it.
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Tip: Display the ruler (in the main menu, click View > Ruler), if you wish to adjust the size any report element,
report part, table. To keep the aspect ratio, use the corner handle to resize an element. This is not necessary,
as the Template takes care of all formatting when a Report Part is drawn in, but it's a good thing to know.

How do I remove a Report Part inserted by mistake?
l If you make amistake and insert the wrong report part, clickUndo and the report part and
associated datasets will be removed.

l If you realize that you have made amistake and after many changes (or a save) you would
like to remove a Report Part, you will need tomove all associated datasets and parameters by
hand (locating them in the Reports Data pane and deleting them by right-click > Delete).

Warning! Using Delete to remove a Report Part will leave the associated datasets behind and
you will end upwith extra datasets and unused parameters in your report.

12. To add a second Report Part, go back to the Technical Summary Report Parts topic and locate the Disk Utilization
Report Part section. TheName to search on in the Report Part Gallery is TechnicalSummary_Chart_Dis-
kUtilization_SQL.

13. Copy the name from the documentation and paste it into the Search Name and Description window in the Report
Part Gallery.

14. Make a note (copy to a file or jot down on paper) of the names of Report Parts that you use in the creation of a
report. Then, when you go to configure the UI controls, you will know which Report Part topics in the online help to
refer to for the order and configuration of UI controls.

Tip: You can use partial names to search and then select the Report Part from the search results.

15. Click the search icon in the window.
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16. The Report Part Gallery refreshes to display the link to the report part.

17. Drag it to the report under the CPU Utilization chart.

18. Add titles to the sections:

a. Click Insert> Text Box and click in the layout, under the title.

b. Type CPU Utilization in the text box and drag it into place.

c. Select CPU Usage andmake it bold.

d. Move the second chart down tomake room for a title.

Tip: Use the handle with the 4 bi-directional arrows to drag the report part around so that you don't lose the
aspect ratio.

e. Click Insert> Text Box and click in the layout, above the second report part.

Tip: Alternatively, you could copy the box you just created and paste it.
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f. Type Disk Utilization in the text box and drag it into place.

19. To this point, we have concerned ourselves with the presentation of the report. To view the data that is now asso-
ciated with this report, find the Report Data pane on the left of the Report Builder screen and click to expand
Parameters andDatasets. All the data necessary for the generation of the report has been pulled into the report
file by the Report Parts.
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20. Save the report.

21. Preview the report in Report Builder. For more information, refer to #5 Previewing Custom Reports in Report
Builder on page 73.

22. Upload the report to Report Manager. Refer to Managing Custom Reports in Report Manager on page 93.

Next step: Use the Executive Summary Template and the Hardware Inventory Report Part to create a report in Creating an
Executive Summary Report with Hardware Inventory on page 59.

Creating an Executive Summary Report with Hardware Inventory
In this topic, we are going to take the Executive Summary Template and add the Hardware Inventory Report Part to create a
useful new report. This also gives us the opportunity to illustrate more of the fundamentals of custom report creation.

Before beginning here, ensure that you reviewed the following: #1 Setting Up an Account for Working in Report Builder on
page 5, #2 Accessing Report Builder on page 8 and at least skimmed Creating a CPU and Disk Utilization Report on page 49.

For this topic we are going to take the Executive Summary Template and add the Hardware Inventory Report Part to create a
useful new report at the same time as we illustrate more fundamentals of custom report creation. This is the result of a few
customer requests to be shown how, andwe are happy to oblige.

After completing this topic, you will have learned about:

l The workflow to follow for all reports using Templates and Report Parts on page 59
l Opening the Template and save it locally on page 60
l Inserting a Report Part into a Template on page 63

The workflow to follow for all reports using Templates and Report Parts

1. Open Report Builder.
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2. Open a Template.
3. Open the Report Manager documentation.
4. For the Template you would like to use, locate the Templates topic in the online help. These topics contain all the

configuration details for the UI controls.
5. For Report Parts, locate the Report Parts topics in the online help. These topics have pictures of all Report Parts,

names to search on and configuration details for the UI controls.
6. For each Report Part that you would like to add to the report layout:

1. Locate the section,Name to search on in the Report Part Gallery.
2. Record the name that you use in a list.
3. Copy the name into the search window of the Report Part Gallery.
4. Click and drag report parts into the report layout and format them.

7. Save the report locally, record the name of the report for your records and a few details to describe it.
8. Upload the report to Report Manager.
9. Use the documentation for the Template to configure the UI controls for it.
10. Follow the list of Report Parts that you have kept and use the documentation for each Report Part to configure

the UI controls.

Opening the Template and save it locally
1. Open Report Builder 3.0. Refer to #2 Accessing Report Builder on page 8.

2. Close theGetting Started page.

3. The work surface is displayedwith a blank report in the design area.

4. In the upper left-hand corner of Report Builder, click the icon and clickOpen.

5. Navigate to your Report Manager server.

6. On the Report Manager server, click Templates.
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7. From the list of Template files, select the Executive Summary Custom.rdl
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8. Open the Template.

The Executive Summary Report Template opens.

9. Re-title the report.
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10. Save the new report locally or to a location to which you have write access (for more information about saving
locally, refer to #1 Setting Up an Account for Working in Report Builder on page 5), renaming the report as you do
this. This is the name that will appear as the title of the report throughout Report Manager.

Example: ExecutiveSummHardwareInv

Inserting a Report Part into a Template
1. Scroll to the end of the Managed Devices section, until Security Monitoring appears.

Warning! Do not click in the report before you scroll. This may select items andmove them with the scroll.

2. Using your mouse, select report items starting with Security Monitoring to the bottom of the report. Use the
anchor in the left corner to drag the that section of the report down andmake room for the report part we are going
to insert into this spot.

Tip: Before you can select items on the page, you have to be able to place your mouse between items.
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3. Open the Report Part Gallery. Click Insert> Report Parts.

4. Locate the Report Parts documentation. Creating Custom Reports> Report Parts> individual files contain
names of all Report Parts.

5. Open the Hardware Inventory Report Parts topic and locate theName to search on in the Report Part
Gallery: HardwareInventory_Table_HardwareInventoryDetails_Model.
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Tip: You can use partial names to search and then select the Report Part from the search results. In this case, you
could type "hardware" and click the search icon to display any report parts with hardware in the name.

Tip: To view all Report Parts in the Gallery, clicking the search icon will populate the Report Part Gallery.
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6. Select the Hardware Inventory Report Part and drag it into the space you've just created.

Report Manager 4.0 How to Create Custom Reports



69

Tip: In the left-hand Report Data pane, expandDatasets and observe that the Hardware Inventory dataset
"dsHardware" has been added to the report.

7. In the Design Pane, trim the Hardware Inventory table. Click into the table to display the table handles, and right-
click to delete one column at a time. Delete the following columns:

l Discovered Name
l Location
l Asset Tag
l OS Installation
l Expected Replacement
l Warranty Expiry
l Lease Expiry
l Purchase Date
l Cost
l First Discovery
l Last Discovery
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8. Fix your view. Scroll horizontally to the right margin of the rectangle containing the Report Part and drag it in to fit
the newly reduced table.

9. Adjust the column widths and the fonts so that the table fits within the report width of 7.5 inches.

10. Select the header row.

11. With the header row highlighted, select the Home tab in the main menu bar at the top, and adjust the font to 6.

12. Do the same for the body row.

13. Reduce the table size to 7.5 inches width. Adjust the columns by clicking and dragging from the right of each col-
umn.
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14. Adjust the width of the rectangles around the title (Hardware Inventory Details) and the tablix by selecting the rec-
tangles and dragging them in to 7.5 inches.

15. Adjust your view of the report page by scrolling to the far right, clicking and dragging it back to 7.5 inches. (The
insertion of the report part expanded the report design view.)

16. Optionally, after reformatting the Hardware Inventory Report Part,you can publish it to the server for reuse.

To publish a Report Part:

a. Click the icon in the top left of the ribbon menu and select Publish Report Parts.

b. Select Review and modify report parts before publishing.

c. Select the check box next to Report parts to clear all check boxes.

d. Select the check box next to the Hardware Inventory report part (HardwareInventory_Table_Hard-
wareInventoryDetails_Model).

e. Click the report part name and rename the report part to somethingmeaningful.

f. Click Publish.
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Tip: To change report properties, such as the orientation of a report right-click the blue background of the report
design surface and select Report Properties from the quick menu that appears.

Previewing a report in Report Builder
1. Click Run in the far left of the ribbon menu.

The report appears in the Run mode.

2. Drag the bottom edge of the portion of the screen with the UI control parameters until all the UI control param-
eters are displayed.
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3. For the purposes of previewing the new custom report before uploading it to Report Manager, provide a Start Date,
an End Date and a Customer (use the Customer ID #).

4. Preview the report in Report Builder. For more information, refer to #5 Previewing Custom Reports in Report
Builder on page 73.

5. Upload the report to Report Manager. Refer to Managing Custom Reports in Report Manager on page 93.

#5 Previewing Custom Reports in Report Builder
After creating a report in Report Builder you can preview it by using the Run feature in the ribbon menu. In order to preview
the report, you will need to supply values for some of the parameters and ID numbers for others. The following parameters
need ID numbers: Device Classes, Folders (Rules), Devices, Services (Services and Service Grouping).

You can obtain the ID numbers to run reports by generating stock reports with the same parameters in Report Manager.

Workflow:

l In the Administration Console, enable Real-time display of Report Values on page 74
l In the Reports Console, run a stock report with the parameters for which you need ID numbers on page 74
l In Report Builder, preview a custom report, using parameter values from stock report. on page 77

Tip: Open Report Manager and Report Builder at the same time and switch between windows.
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In the Administration Console, enable Real-time display of Report Values
1. Sign in to the Administration Console.

2. Navigate toAdvanced Settings (click System Setup and Logs> Advanced Settings).

3. Locate Real-time Display of Report Values.

4. Click Edit.

5. Replace False with True by typing it in and clickUpdate.

This will provide a table with parameter values each time a report is run in the Reports Console. It appears below the gen-
erated report in the screen. You can use the parameter values from this table when you run a Template report in Report
Builder to preview it.

In the Reports Console, run a stock report with the parameters for which you need ID numbers
For this example, use the Availability Comparison report, as it has Customer, Rules (Folders), Devices, and Services param-
eters.

1. Open the Reports Console and navigate to the Availability Comparison Report (clickManaged IT Services> Avail-
ability Comparison Report).

2. Select any start and end dates, select a Customer andRules or Devices, one or more Service and Service Group-
ings and clickGenerate Report.

Tip: You don't have to wait for the report to generate to get this table. The minute you see the report values table, you
can click the Cancel Report Generation button and your selections—the customer, rules or devices,and services
will be displayed in the parameter values table.
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The report generated in HTML:
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The parameter values table, with the following IDs displayed:

l Customer ID
l Rules (Folders) IDs
l Services and Service Groupings IDs
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In Report Builder, preview a custom report, using parameter values from stock report.
1. Open Report Builder. For more information, refer to #2 Accessing Report Builder on page 8.

2. Open a Template. For this example, open the Availability Comparison Custom. (Click the icon in the top left > Open and
navigate to the Templates folder on your report server. Refer to Templates.)

3. Click Run in the ribbon menu to run the report for preview.
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4. Provide start and end dates and the required parameter IDs: Customer ID, Services and Service Groupings. Click the drop-
down beside the parameter name, and type the ID in the middle box. For multiple ID numbers, place them on separate
lines. They will appear in the text box with commas after the next click.

Tip: You only need to provide one ID for parameters with multiple IDs listed to preview the report.

5. Click View Report.

The report renders below the parameters.
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6. Return to the design view (clickDesign) to make any changes to the report.

#6 Configuring UI Controls in Report Manager

What are Parameters ? U I Co n t ro l s ?

Parameters specify the data to use in a report. They allow you to filter data, vary appearance, and connect
to re lated reports. When you create a report parameter and run a report, you enable the user to choose
values for the report parameter. In your report, you can write expressions that re fer to the value of the
parameter at run time and change the data or appearance of the report. Parameters are a lso used when
you include a link to another report or to a subreport from your main report.

The UI contro l or Parameter Type determines how the user se lects input for the parameter at run time.
Examples of UI contro ls: pick lists, check boxes, text boxes, date fie lds. The Parameter Type for user input
must be matched to Data Type.

Before reading this topic, you may want to review How to Create Custom Reports on page 4, if you have not already.

After completing this topic, you will have learned about:

l The two Modes: Simple and Advanced
l What it means to edit the UI controls: Side-by-side editing and runtime
l How to upload a Template and configure UI controls
l How to set up a Validation Group
l How to set up Data Dependency
l How to set up Visibility Dependency
l About Required Field and Default Value
l UI control features: Definition and Description

The two Modes: Simple and Advanced
There are twomodes in which to view the UI control configuration screen in Custom Report Management: Simple and
Advanced.
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Simple Mode
Simple Mode is visible when:

l A custom report is uploaded, and UI configuration is required
l A custom report is edited through the Custom Report Management screen

In Simple Mode you can:

l Reorder the prompts as they appear in the UI for the user at run time
l Edit the hint help if required
l View and edit Parameter Type if required

Advanced Mode
After the Advanced Mode check box is selected, the following additional UI control properties appear:

l Validation Groups
l Data Dependency
l Visibility Dependency
l Required Field
l Default Value
l Insert Line Above
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What happens when I edit the UI controls?
You can edit the properties of UI controls which determines what the user will see at runtime.

The screen shot, "Editing and Runtime", below shows two views of the Availability Comparison Template. On the left
is the Editing view. This is what you see when editing UI control parameters in the Custom Report Management (CRM)
screen in the Administration Console. On the right is the Runtime view. This is what the user sees at runtime when
they are setting up the report to run.

When you are in Custom Report Management:

l You can reorder the prompts to determine how they will display at runtime.
l You can provide the hints that will display for the user.
l You can set up data dependency on UI controls, so that the selection of one UI control parameter populates
another. For more information, refer to How to set up Data Dependency on page 84.

l You can hide some items andmake their visibility dependent on the selection of another item. For more infor-
mation, refer to How to set up Visibility Dependency on page 87.

l You can parameters. This allows a user to select one item from any of the group to populate a list, or forces the
user to make a selection from one of a group. For more information, refer to How to set up a Validation Group on
page 83.

l You can provide visual separation of the UI at runtime by inserting a line across the UI screen.
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How to upload a Template and configure UI controls
You can upload the same version we are using by going directly to a version of the Availability Compliance Template
that was provided in your installation directory. We are going to talk about each column in the Custom Report Man-
agement screen in order of appearance, left to right.

1. Sign in to the Administration Console.

2. Click Custom Report Management.

3. ClickUpload Custom Report.

4. Click Browse and navigate to your local installation directory,N-able Technologies> Report Manager >
reports> Templates> Availability Comparison Custom.rdl.

5. ClickOpen.

6. ClickNext.

The report opens in the "Simple Mode".
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7. In Simple Mode, you can do the following:

l Reorder the prompts as they appear in the UI for the user at run time
l Edit the hint help if required
l View and edit Parameter Type if required

8. Select the Advanced Mode check box.

How to set up a Validation Group

What i s a Val i d at i o n G ro up ?

Validation Groups are created when two or more parameters are assigned to a validation group
through Custom Report Management in Report Manager. You might like to group UI contro ls for the
fo llowing reasons:To allow a user to pick any of the contents of the grouped UI contro l types to filter
the contents of a dependent UI contro l. To force a user to pick at least one of a group of UI contro ls,
for example, one of a group of check boxes.

We are going to create a Validation Group and include the following parameters: Device_Class_ID, Rule_ID, and
Device_ID.

1. Locate the Validation Groups column

2. Select the + icon in the top right of the Validation Groups column header and type "GRP_1".

Note: You can name a Validation Group anything you like, the suggestion is to start with 1, and then 2, and so on.

Report Manager 4.0 How to Create Custom Reports



84

3. Click the + button.

4. In the Validation Groups column, assign the following to GRP_1

l Device_Class_ID
l Rule_ID
l Device_ID.

At run time, the Service List UI control will be populated when the user selects a Device Class, or a Rule, or a
Device.

How to set up Data Dependency

What i s Data Dep end en cy?

Data Dependency allows filter ing of the contents of one parameter type based on the se lection of
another.

Data dependency is editable in Advanced Mode.

1. Click the drop-downs to view the dependencies available for each of the following UI controls: Device Class List, Rule
List, Device List, and Service List. The number of parents for a UI control grows as the UI control descends the hier-
archy in the database. Device Class List has only one parent to be dependent upon; Service List has a possibility of
four parent UI controls.
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2. When a user selects a Customer, we want Device Class List, Rule List and Device List populated for that customer,
without any filtering, other than on Customer (no water fall effect).

For each of the these UI controls, select Customer List from the Data Dependency drop-down.

Device Class List, Rule List and Devices List are populated (and filtered on Customer) when a Customer is selected
from the Customer List box.

3. You may have noticed that there are+ and - toggles under each of the drop-down lists in theData Dependency
column.

4. For Services List, click the+ under theData Dependency drop-down twice to add twomore UI controls as parent
controls.

5. Click the first drop-down and select Rule List.

6. Click the second drop-down and select Device Class List.

7. As these UI controls have already been grouped (GRP_1) this means that when any of these controls are selected,
the Service List control will be populated.

Learn more
Review the screen in Simple Mode. Parameter types have been matched to Data Types and Data Dependency for
the following Parameter Types (UI controls that user will work with at run time) has been filled in:
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Parameter Type/UI Control Data Dependency

Device Class List Customer List

Rule List Device Class List

Device List Rule List

Service List Device List

These dependencies are a direct reflect of the hierarchy of UI controls that exists in the database, listed in the fol-
lowing table:

Child Parameter Type Parent Parameter
Type

Customer List SO Customer List

Service List Device List

Device Class List Customer List

OS List Device List

Device List Rule List

Rules List Device Class List

Event Category List Device List

Hierarchy of UI Controls

At run time all Lists except Customer are empty and they will populate (and be filtered) according to the user's selec-
tion.

l Device Class List populates when a Customer is selected.
l Rules List populates when a Device Class is selected.
l Device List populates when a Rule is selected.
l Service List populates when a Device is selected.
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This kind of dependency hierarchy is called a waterfall with each subsequent parameter being filtered by the pre-
vious selection within the established hierarchy.

We are looking at the underlying dependencies and the hierarchy only as a starting point to explain this screen and
to explain the underlying logic of the database.

Custom Report Management uses the underlying logic of the database to allow you to group dependencies in a logic
suitable to the report.

To reassign dependencies, and to provide for grouping of UI controls, we need to view the report parameter con-
figuration in the Advanced Mode.

How to set up Visibility Dependency

What i s Vi s i b i l i t y Dep end en cy?

Vis ibility Dependency allows one UI contro l to be v is ible based on the se lection of a check box at run
time. This he lps to keep the UI organized and easy to read. An example of v is ibility dependency in
the stock reports is the UI Control "Include Time Based SLA Breakdowns". I f this check box is
se lected, the UI contro ls for the fo llowing appear: A ll Day, Start Time, End Time and Days. Each of
these UI contro ls has a v is ibility dependency based on the se lection of the UI contro l "Include Time
Based SLA Breakdowns".

For the Availability Comparison Custom we are going to configure a visibility dependency on the Included Time Based
SLA Breakdowns check box for the other UI controls: Start Time, End Time, Days, exactly the same as the example in
the definition, above.

1. For parameter names:Start_Hour, End_Hour andWeekType, select IncludeBreakdown from the Visibility
Dependency drop-down.
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About Required Field and Default Value
In Report Manager, assigning a default value for a UI control that is a required field will make the field optional. The
Required Field property is not editable in Report Manager. Required fields will force user input at run time. If you would
like to make a field a required field, you can do so through Report Builder.
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How to configure Hint Help
Hint help is easily configured through Report Manager. Limit on hint help: 500 characters.

l Click in the Hint Help field and type a hint.

Refer to the Template and Report Parts topics for specific Hint Help.

How to Insert Line Above
The last column in the Custom Reports Management screen allows you to divide up the interface at run time using
lines. An example of the usefulness of this is in the Executive Summary Report, where lines separate sections.
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UI control features: Definition and Description

Property Description About

Prompt The Prompt is the label the user will see next to the input field for the parameter in the UI at run
time.
You can use the up and down arrows on the left of the prompts to reorder the user prompts as
they will appear in the Reports Console UI.

You can
reorder
prompts,
but not
rename
them.

Parameter
Type (UI
control)

The Parameter Type, or UI control determines how the user selects input for the parameter.
Examples of UI contosl: pick lists, check boxes, text boxes, date fields.
The Parameter Type for user input must be matched to Data Type.

You can
select
from a
list of
types.

Parameter
Name

The Parameter Name is the name associated to the parameter. It is assigned when the parameter
is created, either manually or during dataset creation. When reports are being created, careful
thought should be given to the parameter name that will identify it so that it is clear to the user
what input is required. This field is not editable in Report Manager but can be edited in Report
Builder. The name is case-sensitive, begins with a letter and has letters, numbers, an under-
score (_), and no spaces, for example, ReportParameter_1. For automatically-generated param-
eters, the namematches the query parameter in the dataset query.

Not edi-
table, you
can
change
the name
in Report
Builder.

Data Type The Data Type is a property of the parameter that determines the Parameter Type or UI Control
that can be used for user input. The following data types are available in Report Manager: Text,
Integer, DateTime, Boolean, String, Float

Not edi-
table

Hint Help The Hint Help will appear when a user rolls their mouse over the hint icon. Editable

Data
Dependency

Data Dependency allows filtering of the contents of one parameter type based on the selection of
another.
In Simple Mode, this is informational. In Advanced Mode, this becomes editable.

Editable
in
Advanced
Mode

Visibility
Dependency

Visibility Dependency allows one UI control to be visible based on the selection of another UI con-
trol (always a check box) at run time. This helps to keep the UI organized and easy to read. An
example of visibility dependency in the stock reports is the UI Control "Include Time Based SLA
Breakdowns". If this check box is selected, the UI controls for the following appear: All Day,
Start Time, End Time and Days. Each of these UI controls has a visibility dependency based on
the selection of the UI control "Include Time Based SLA Breakdowns".

Advanced
Mode
only

Custom Report Management Editing Screen Described
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Property Description About

Required
Field

A Required Field forces user input before the report can be generated. Advanced
Mode
only
Not edi-
table

Default
Value

Applies to a required field. When a Default Value can be provided for a required field, user input
becomes optional for the field.

Advanced
Mode
only
Editable

Validation
Groups

Validation Groups are created when two or more UI control types for parameters are assigned to
a validation group. A Validation Group allows users to pick any of the contents of the grouped UI
control types to filter the contents of a dependent UI control type.

Advanced
Mode
only
Editable

Insert Line
Above

When selected, Insert Line Above places a line in the UI above the associated UI control.
This creates a visual separation between sections of the report for user input.
Good examples for its use are the Executive Summary Custom report which has many sections,
or above a check box on which other UI controls have a visibility dependency and above the last
item with visibility dependency.

Advanced
Mode
only
Editable
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Managing Custom Reports in Report Manager

The Custom Report Management screen in Report Manager your portal to custom reporting. Through this screen, you can do
the following:

l Filter your view or search for custom reports, subreports and report parts within the system
l Upload custom reports, report parts, subreports
l Open Report Builder
l Connect directly to the Reports Library in the NRC
l Update an RDL file by uploading it again
l Edit the UI controls for custom reports

1. In the N-central navigation pane, click Administration > Report Manager > Administration Console.

2. Click Custom Report Management.

3. To keep your view more manageable, use the check boxes to filter your view to only the report type you are interested in:
custom reports, subreports or report parts that you have uploaded to your server.

4. You can also search on partial names of custom report items. This is a new feature in Report Manager 4.0. For example,
type "exec" in the Search Name and Description window and press Enter to view all executive summary report items that
have been uploaded to your server.
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Tip: The search will only be performed on the Report Type selected. For example, if only Report Parts is selected, the
search will only return report parts matching the search string.

5. Through this screen, you can do all of the following:

l Upload a custom report to the Report Manager server
l Open Report Builder (Note: If you have installed Service Pack 2 for SQL Server 2008 R2, you need to use a stand-alone
Report Builder, version 10.50.1600.1. For more information, refer to #2 Accessing Report Builder on page 8.)

l Connect directly to the Custom Reports Library
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For more information, refer to Uploading a Custom Report File on page 95 and#2 Accessing Report Builder on page 8.

6. You can Update the RDL file of the same name. For more information, refer to Uploading a Custom Report File on page
95.

7. You can Edit the UI controls, which determine how the user provides input at run time. For more information, refer to #6
Configuring UI Controls in Report Manager on page 79.

Note: UI controls for Subreports and Report Parts cannot be edited.

Uploading a Custom Report File
You can upload the following to the Report Manager server:

l Custom reports
l Report Parts
l Subreports
l Updated RDL files

To upload a custom report
1. Sign in to N-central.

2. In the N-central navigation pane, click Administration > Report Manager > Administration Console.

3. Click Custom Report Management.

4. ClickUpload Custom Report.

5. Click Browse to navigate to the report (.rdl) you would like to upload.

6. Select a file and clickOpen.
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The Report Parameter Configuration page for this report file appears. For more information on configuring UI con-
trols, refer to #6 Configuring UI Controls in Report Manager on page 79.

To upload a Report Part
1. Sign in to N-central.

2. In the N-central navigation pane, click Administration > Report Manager > Administration Console.

3. Click Custom Report Management.

4. ClickUpload Custom Report.

5. Click Browse to navigate to the report part (.rsc).

6. Select a file and clickOpen.

Report Manager detects the file extension and prompts you for a description of the report part.

7. In the Report Description field, type a description for the report part.

The screen displays a success page and redirects you to the Custom Report Management screen.

To upload a Subreport
1. Sign in to N-central.

2. In the N-central navigation pane, click Administration > Report Manager > Administration Console.

3. Click Custom Report Management.

4. ClickUpload Custom Report.

5. Click Browse to navigate to the file you need to upload as a subreport (.rdl).

6. Select the file and clickOpen.

7. Select Upload as a Subreport.

8. ClickNext.

The screen displays a success page and redirects you to the Custom Report Management screen.

To update an RDL file
You can make changes to an RDL file and upload it again to the Report Manager server using the same RDL file name.
This will overwrite the original file and keep scheduled reports and any UI control parameter configuration you have
already made.

Examples of changes that you can make to an RDL: Formatting changes, UI prompt labels, or corrections to a cal-
culation error.

Warning! If you change the number of parameters, parameter name, parameter data type, or the name of the RDL
file, the file cannot be updated.

1. In the N-central navigation pane, click Administration > Report Manager > Administration Console.

2. Click Custom Report Management.

3. Next to the report file that you would like to replace, clickUpdate.

4. Click Browse and navigate to the updated file on the server.
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5. Select the file and clickOpen.

6. ClickNext.

The screen displays a success page and redirects you to the Custom Report Management screen.

Deleting a Custom Report File
You can remove a custom report from the Report Manager server through the Administration Console.

To delete a custom report file
1. In the N-central navigation pane, click Administration > Report Manager > Administration Console.

2. Click Custom Report Management.

The Custom Report Management screen appears.

3. Select the check box next to the Report Name of the custom report you want to delete.

4. On the confirmation screen, clickDelete.

The report is removed from the server.
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Resources for Custom Report Creat ion

This section includes:

l Tips and Tricks on page 99—Find answers to some questions users have had and some gotchas we've uncovered in our
work with Report Builder. We are always looking for more suggestions for this section.

l Restoring Templates on page 98—If you accidentally overwrite a Template, you can restore the original using these
instructions.

l Previewing Templates in Report Manager on page 98—Use sample Templates to plan your reports. You can preview the
information in the Template or Report Parts andmake decisions about which ones to use.

l Data Tables on page 110—Advanced users will find dimension and fact tables for Report Manager here to use in the cre-
ation of custom reports.

l About Report Builder and Report Manager on page 114—Which versions of SQL Server and Report Builder are com-
patible? What are the roles of Report Manager and Report Builder in custom report creation.

l More Reading on page 114—The details of some books we recommend to round out your reporting knowledge.

Restoring Templates
You can replace a Template on the Report Manager server if it gets accidentally overwritten. Template files have been stored in
your installation directory for just such a situation.

(No one is perfect. Review the topic #1 Setting Up an Account for Working in Report Builder. This topic outlines the best prac-
tice of designating a specific account for report creation that won't allow report creators to overwrite the Templates.)

1. On the Report Manager server, open a browser and type: http://localhost/reports to open the SQL Server Reporting Serv-
ices Home page.

2. Click the Templates folder to open it.

3. Locate the template that you need to replace and hover over it to display a drop-down.

4. Click the drop-down to open the menu.

5. From the menu, clickManage.

6. On the next screen, in the menu bar, click .

7. On the next screen, click Browse to locate to the same named report in your installation directory (N-able Tech-
nologies> Report Manager > reports> Templates).

8. Select the Template.

9. ClickOpen.

10. ClickOK.

The Template from your installation directory has now replaced the copy on the Report Manager server.

Previewing Templates in Report Manager
You can preview Templates before going ahead andmaking any changes to them in Report Manager to make decisions about
which ones you would like to use.
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When Report Manager was installed, an extra set of Templates was copied to your installation directory. This set was intended
as a back up if the Templates stored on the Report Manager server got accidentally overwritten. This folder also contains con-
figuration files (.xml) for the Templates. These configuration files provide parameter properties such as the parameter type,
dependencies, validation groups and also fill in hint help for you.

1. In the N-central navigation pane, click Administration > Report Manager > Administration Console.

2. Click Report Manager.

3. ClickUpload Custom Report.

4. Click Browse and locate the installation directory on your Report Manager server.

5. Navigate toN-able Technologies> Report Manager > reports> Templates.

Within the Templates folder you will find all the available Template RDL files. In addition, you will find a configuration file
for each RDL, which you can upload at the same time as you upload the report. The configuration file provides each param-
eter with values and UI controls.

For example: If the RDL file is Technical Summary Custom.rdl, the Configuration file will be Technical Summary Custom
Parameters.xml

6. Select the Template file (.rdl) and clickOpen.

7. Select theUpload a Config File check box.

8. Click Browse to navigate to the configuration file (.xml) for the Template.

9. Select the file and clickOpen.

10. ClickNext.

The Custom Report Management screen appears and the selected Template is listed.

11. To view the UI control parameters, click Edit next to the Report Name.

The Template is now available to be previewed through the Reports Console.

Tips and Tricks
This topic catalogues some nice to know and frequently needed tidbits for custom reporting. We encourage you to contact us
and provide us with your favorites so we can include them here.

l What is the fastest way to open and use Report Builder?

l How do I find Customer ID?

l How do I find parameter ID numbers? on page 101

l Why don't we filter on Customer Name?

l How do I locate Report Parts in Report Builder?

l How do I find a data source if Report Builder isn't showing one? on page 104

l How do I remove the Values column?

l How do I edit a dataset (return to the Query Designer)? on page 101
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l How do I remove a Report Part inserted by mistake? on page 104

l How do I find a data source if Report Builder isn't showing one? on page 104

l How to set up the workspace and select page settings on page 104

l How do I insert and format a table? on page 109

l How do I add a dataset? on page 106

l How do I change report properties? on page 110

l How do I change report properties? on page 110

What is the fastest way to open and use Report Builder?
Answer

You can download and install the stand-alone on the Report Manager server and open Report Builder 3.0 directly.
(Reminder: Report Builder 3.0 is only available through SQL Server 2008 R2.)

Warning! Ensure that you use the credentials for an account that prevents overwriting of Templates. For more infor-
mation refer to #1 Setting Up an Account for Working in Report Builder on page 5.

1. Download the stand-alone installer for Report Builder 3.0 from the Microsoft Download Center (http://ww-
w.microsoft.com/en-us/download/details.aspx?id=6116).

2. Follow the instructions in the installer, clickingNext for each screen, until theDefault Target Server screen.

3. For Default target server URL, provide the following: http://*ip*/reportserver where *ip* is your local Report Man-
ager server IP.

4. ClickNext.

Report Manager 4.0 Resources for Custom Report Creation

http://www.microsoft.com/en-us/download/details.aspx?id=6116
http://www.microsoft.com/en-us/download/details.aspx?id=6116
http://www.microsoft.com/en-us/download/details.aspx?id=6116


101

5. Open Report Builder from the Start Menu or pin it to the Taskbar before beginning your custom report work.

How do I edit a dataset (return to the Query Designer)?
Answer

In the Report Data pane, right-click the dataset and clickQuery.

How do I find Customer ID?
Answer #1

1. Open Microsoft SQL Server Management Studio on your Report Manager Server.

2. In the left pane, expandDatabases>Warehouse > Tables.

3. In the right pane, right-click dim_Customer.

4. Click Select Top 1000 Rows.

5. In the Results tab at the bottom, details for customers are displayed, including the Customer ID for each Cus-
tomer.

Answer #2

l To find all parameter ID numbers, refer to #5 Previewing Custom Reports in Report Builder on page 73.

How do I find parameter ID numbers?
To preview reports in Report Builder you will need ID numbers for many parameters.

l To find all parameter ID numbers, refer to #5 Previewing Custom Reports in Report Builder on page 73.

Why do we filter on Customer ID and not Customer Name?
Answer

IDs are always used for filters. Report Manager uses Customer ID tomap to the Customer List UI control.
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Using IDs instead of names to identify customers makes good sense, from a database perspective. It promotes scal-
ability.Report Manager stores data for a long time and if a customer is removed from Report Manager and subsequently
returns, the customer namemay be the same, but the Customer ID will always be unique. In addition, if you have mul-
tiple servers, it avoids confusion of different customers with the same name.

How do I remove the Values column?
Arrange fields Values issue

You must put a field in the Values box in order to leave the Arrange Fields page. This is because Report Builder has been
designed to suit a wide audience and, in particular, it's been designed to suit reports meant for accounting purposes.
Values are useful when you need to create totals and subtotals, for example, if you were creating a CPU Utilization
Report.

On the far right of the table will be the Values column that you were forced to add to the report just to leave the screen,
Arrange Fields.

Answer

You can hide it from view. It helps to conserve real estate in the report layout.

1. Click in the table to select it.

2. Click the column itself to select it.

3. Right-click the column top border to display the menu:

4. Click Column Visibility.

5. In the Change display options dialog, select Hide.

When the report is run, this column will not be visible.

How do I locate Report Parts in Report Builder?
Answer

If you know which Report Parts you would like to use, you can locate a Report Part in the Report Part Gallery by search-
ing on the name or part of the name.

1. In Report Builder, open the Report Part Gallery (Insert> Report Part).

2. Select the Details icon.
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3. Copy and paste the name of the Report Part you are interested in, or a part of the name in the Search window, to dis-
play a filtered list of Report Parts.

Tip: If you would like to hide or delete some of the columns in the Hardware Inventory Details table, click in the
table and right-click the column to display the menu for each column. Hide or delete as you prefer.
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How do I remove a Report Part inserted by mistake?
l If you make amistake and insert the wrong report part, clickUndo and the report part and associated datasets
will be removed.

l If you realize that you have made amistake and after many changes you would like to remove a Report Part,
you will need tomove all associated datasets and parameters by hand (locating them in the Reports Data pane
and deleting them by right-click > Delete).

Warning! Using delete to remove a Report Part will leave the associated datasets behind and you will end upwith
extra datasets and unused parameters in your report.

How do I find a data source if Report Builder isn't showing one?
If Report Builder is not showing you a list of pre-loaded data sources:

1. Click Browse,

2. Type http://localhost/reportserver/Models.

3. SelectWarehouse and clickOpen.

How to set up the workspace and select page settings
If you used a blank report to create a custom report, you can set up the ruler units within Report Builder in order for
your report to display and print correctly.

1. In the View tab, clear the check boxes for Properties andGrouping. This opens upmore real estate for us.

2. Select Ruler.
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3. Right-click on the blue screen beside the layout and select Report Properties.

4. Set the units and dimensions appropriately for your report. For a standard portrait sized report, set ruler to 7.5
inches. Report Builder has a default border of .5 inches all the way around.
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How do I add a dataset?
This information comes from the topic, Creating a Missing Patches Report on page 26

1. Right-clickDatasets, click Add Dataset.

2. Type in a new name for the dataset: with no spaces in the name).

3. Select Use a dataset embedded in my report.

4. Select the data source.

5. ClickQuery Designer.
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6. In the Entities list, select the table, for the example we selectedDim Customer.

The following things change:

l The selection ofDim Customer filters the available Fields to those that are related toDim Customer.
l Customer is now bolded because it's been used.

Note: Remember, this is data collection, not the report design. In general, when designing future reports, add as
much information here as you think you could possibly use. Locate tables of interest either by scrolling or
clicking the search icon.

7. In the fields list, select a field, in this example, Customer Namea, and drag it to the right pane and drop it in the
collection field.

8. In the Entities list, clickDim Devices.

Tip: Fields are not in alphabetical order, so you can use the search button or scroll.
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9. Click and dragDevice Class into the right collection field.

10. Click and dragDevice Name into the right collection field.

11. Widen the columns so you can see the names, by clicking a column and dragging the right column edge over.

Tip: When you drag a field into the collection screen, look for the blue bar before dropping the field.
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Tip: If you drag a field into the collection screen by mistake, right-click the column and clickDelete.

How do I insert and format a table?
l For detailed information on inserting and formatting a table through the Table Wizard, refer to Creating a Missing
Patches Report on page 26.

How do I edit... text boxes, images, data regions?
l In the View tab, selectingPropertieswill display the Properties Pane on the right of the page where you can
edit the properties of every item in a report, the body, images, text boxes, data regions and so on.When you
select or edit an item in the Report Design area, the Properties Pane refreshes to display the properties asso-
ciated to the item, as shown.

How do I publish a Report Part?
1. Click the icon in the top left of the ribbon menu and select Publish Report Parts.
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2. Select Review and modify report parts before publishing.

3. Select the check box next to Report parts to clear all check boxes.

4. Select the check box next to the Hardware Inventory report part (HardwareInventory_Table_Hard-
wareInventoryDetails_Model).

5. Click the report part name and rename the report part to somethingmeaningful.

6. Click Publish.

How do I change report properties?
To change report properties, such as the orientation of a report right-click the blue background of the report design sur-
face and select Report Properties from the quick menu that appears.

Data Tables
The data warehouse schema consists of dimension and fact tables. A dimension is a structure that categorizes data in order to
enable users to answer business questions. Fact tables contain the measurements or metrics or facts of business processes.

We have provided you with the dimension and fact tables for Report Manager to use in the creation of custom reports.

Dimension Fact Tables

Fact Table Granularity Description

dim_Customer one row per customer list of customers

dim_Datasource one row per datasource list of datasources

dim_Date one row per date simple representation of dates
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dim_Device one row per device list of devices

dim_Folder one row per folder list of folders

dim_Interface one row per interface list of traffic interfaces

dim_Service one row per service/service item list of services

dim_Status one row per status list of statuses

dim_Time one row per minute simple representation of times

dim_Utilization Type one row per utilization type used to join utilization tables

dim_VoIP Resources one row per VoIP resource type used to join VoIP tables

Fact Tables

Fact Table Granularity Description

fact_Application License Compliance 1 row per hour, span each scan
hourly

Details which applications are not in
compliance.

fact_Availability 1 row per state transition per task Details the availability of a device for
all of the availability services or serv-
ice groupings.

fact_AvailabilityHourly

fact_BackupServices 1 row per scan Details about all monitored Backup
Exec services. Includes backup, con-
fig, and restore options.

fact_Bandwidth 1 row per hour, span each scan
hourly

Details about traffic services on eth-
ernet devices, such as switches or
routers.

fact_cim_application

fact_cim_computer system

fact_cim_custom last loggedin user

fact_cim_Folder For Share

fact_cim_Logical Device

fact_cim_Mapped Drive

fact_cim_MissingPatch 1 row per data-
source/customer/device/patch com-
bination.

Table stores missing patch infor-
mation such as when patch was
released, patch category, whether or
not patch was installed or if there was
a failure installing it.

fact_cim_media access device
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Fact Table Granularity Description

fact_cim_Network Adapter Con-
figuration

fact_CIM_NetworkAdapter 1 row per network adapter Detected network adapters for all dis-
covered devices.

fact_cim_OpenPorts

fact_cim_operating system

fact_cim_Page File

fact_cim_Patch

fact_cim_processor

fact_cim_Service

fact_cim_Video Controller

fact_Cost of Downtime 1 row per day Tracks the assigned cost of downtime
for all service groupings over time.

fact_Device Folder 1 row per device/folder combination Tracks which devices associated to
which folder over time.

fact_Device License Compliance 1 row per hour, span each scan
hourly

Details which devices have appli-
cations that are not in compliance.

fact_Device License Compliance
Details

1 row for each application out of
compliance on a device

Contains the details of the application
causing the devices to be out of
compliance.

fact_Device Management History 1 row per device discovered Lists the start and, if applicable, end
date of management of a device.

fact_Device Note

fact_Device Property

fact_Device Service Parameters 1 row per task parameter Describes the parameters for tasks.

fact_Device Services 1 row per device/service combination Tracks which service is being mon-
itored on devices over time.

fact_Disk_QueueLength

fact_EventLog 1 row per unique event per hour Detected events for all monitored
devices.

Fact_EventLog_Categories

fact_Incident 1 row for each incident (device/serv-
ice)

Details notifications sent per incident
from the central server.
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Fact Table Granularity Description

fact_IncidentDevice

fact_IncidentService

fact_IncidentTicket 1 row per data-
source/customer/ticketid com-
bination

Table stores id for an incident ticket,
if it was resolved and when the ticket
was opened.

fact_ManualTicket 1 row per data-
source/customer/ticketid com-
bination

Table stores id for an manual ticket, if
it was resolved and when the ticket
was opened.

fact_Notification 1 row per notification detected by the
central server

All notifications sent by the central
server.

fact_PacketLoss

fact_PrinterPaper

fact_PrinterToner

fact_Remote Control Usage 1 row per remote control attempt Decribes the details of a remote con-
trol connection.

fact_SEM Anti-virus Activity 1 row per status for each scan hour Status of all anti-virus activity serv-
ices for all monitored devices.

fact_SEM Anti-virus Definition 1 row per status for each scan hour Status of the anti-virus definition serv-
ices, for all monitored devices.

fact_SEM_Firewall Incidents 1 row per status for each scan hour All firewall incidents detected for all
monitored devices.

fact_SEM_Patch Level 1 row per status for each scan hour Patch level status for all monitored
devices.

fact_SEM_Patch Level Count 1 row per scan Counts the total number of missing
patches per scan.

fact_SEM_Patch Level Daily Status 1 row per task per day Final daily patch level status.

fact_Utilization 1 row per hour, span each scan
hourly

Shows utilization of CPU, disk, phys-
ical memory, and virtual memory on
devices.

fact_VoIP Call Activity 1 row per hour, span each scan
hourly

Call activity statistics for all monitored
CCM devices.
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Fact Table Granularity Description

fact_VoIP Device Registration 1 row per hour, span each scan
hourly

Device registrations for all CCM
devices.

fact_VoIP Incidents 1 row per hour, span each scan
hourly

All incidents detected for all mon-
itored CCM devices.

fact_VoIP Information 1 row per hour, span each scan
hourly

VoIP device information for all CCM
devices.

fact_VoIP Resource Utilization 1 row per hour, span each scan
hourly

VoIP resource utilization for all mon-
itored CCM devices.

About Report Builder and Report Manager
Report Builder is a small report design tool that is installed on your report server as part of Microsoft SQL Server. Similar in look
and feel to Microsoft Word, it is a comfortable environment for users of other Microsoft Office tools. You can create simple or
complex reports very quickly through wizards and an intuitive interface. If you have SQL and scripting skills you can customize
SQL queries within Report Builder, but it is often just as quick to follow the UI and use the wizards.

Roles of Report Builder and Report Manager
Report Builder is where you have access to Templates and Report Parts provided by Report Manager (created from existing
stock reports), tools to create custom reports varying from simple to complex and preview the reports.

Report Manager is where you upload the custom reports, configure UI controls, update an RDL, and ultimately, custom report
users run the reports.

About Microsoft SQL Server and Report Builder Versions
SQL Server 2008 R2 supports Report Builder 3.0, which allows for creation of reusable and editable reports, including the cre-
ation and use of Report Parts.

More Reading
We recommend the following:

l Microsoft SQL Server 2008 Reporting Services, by Brian Larson, ISBN-10: 0071548084, ISBN-13: 9780071548083
l Microsoft® SQL Server® 2008 Reporting Services Step by Step, by Stacia Misner, ISBN-10: 0-7356-2647-2, ISBN-13:
9780735626478

Report Manager 4.0 Resources for Custom Report Creation
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Customer Support

Online: http://www.n-able.com/support/

Email: Support@n-able.com

Phone us: 1-866-302-4689 (US/CAN)

+800 6225 3000 (International)

Report Manager 4.0 Customer Support



Disclaimer

This document may include planned release dates for service packs and version upgrades. These dates are based on our cur-
rent development plans and on our best estimates of the research and development time required to build, test, and implement
each of the documented features. This document does not represent any firm commitments by N-able Technologies Inc. to fea-
tures and/or dates. N-able Technologies will at its best effort, try to meet the specified schedule and will update this document
should there be any significant changes. N-able Technologies reserves the right to change the release schedule and the con-
tent of any of the planned updates or enhancements without notice. Publication or dissemination of this document alone is not
intended to create and does not constitute a business relationship between N-able Technologies and the recipient.

Feedback

N-able Technologies is a market driven organization that places importance on customer, partner and alliance feedback. All
feedback is welcome at the following email address: feedback@n-able.com.

About N-able Technologies

N-able Technologies is the global leader in remote monitoring and management software for managed service providers and IT
departments. N-able’s award-winning N-central platform and complementary toolsets, backed by best-in-class business and
technical services, are proven to reduce IT support costs, improve network performance and increase productivity through the
proactive monitoring, management and optimization of IP-enabled devices and IT infrastructure. N-able is 100% channel-
friendly and maintains operations in North America, the U.K., the Netherlands and Australia.

Copyright © 2013 N-able Technologies

All rights reserved. This document contains information intended for the exclusive use of N-able Technologies' personnel, part-
ners, and potential partners. The information herein is restricted in use and is strictly confidential and subject to change with-
out notice. No part of this document may be altered, reproduced, or transmitted in any form or by any means, electronic or
mechanical, for any purpose, without the express written permission of N-able Technologies.

Copyright protection includes, but is not limited to, program code, program documentation, and material generated from the
software product displayed on the screen, such as graphics, icons, screen displays, screen layouts, and buttons.

N-able Technologies, N-central, and Report Manager are trademarks or registered trademarks of N-able Technologies Inter-
national Inc., licensed for use by N-able Technologies, Inc. All other names and trademarks are the property of their respective
holders.
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