Device does not show in All Devices tab after manual installation

Last Modified

Fri Apr 13 15:55 GMT 2018

Description

  • The device does not show up in the All Devices tab after installing the agent manually on the device.

Environment

  • N-able N-central 10.0 and later

Solution

Cause
  1. The device is still in the import device list because the device class is not set in the auto import in the discovery defaults.
  2. The device is still in the import device list because it was marked as ignored
  3. The device has been discovered as a duplicate for another device. In this case, you will need to seek assistance from N-able support
Resolution
  1. Check that your discovered device is in the import list in Customer level > Actions > add/import devices > Discovered devices.
    1. It may be necessary to check the "Show Ignored Devices" checkbox near the top of the device list.
  2. If the device is not there, check that the following services are started on the remote device:
    Windows Agent Maintenance Service
    Windows Agent Service
  3. If the device has an incorrect IP/FQDN of the N-able N-centralserver:
    a. Select the device from the All Devices View.
    b. Select the Settings > Local Agent tab.
    c. Ensure that the Server Address is correct.
    d. On the remote device open the C:\Program Files (x86)\N-able Technologies\Windows Agent\config\ServerConfig.xml file with Notepad
    e. Modify the following string:
    <ServerIP>central server IP or FQDN</ServerIP>
    <BackupServerIP>central server IP or FQDN</BackupServerIP>

    f. Save the file and restart the Windows Agent services listed above.
  4. Check that your device is able to communicate with the N-able N-central server by opening a browser and try to reach N-able N-central server through HTTPS.
  5. If the above steps do not solve the issue, kindly open a case with N-able N-central support.